A sound problem (geek edition)

How annoying! My soundcard is back to its old tricks of popping and clicking while I’m listening to MP3s and typing. I know what you’re going to suggest: well, Gareth, don’t do those two things at the same time! … just, don’t go there!

I wondered if the problem was with my onboard soundcard interfering with the new. So I uninstalled my Creative Sound Blaster Audigy 2 drivers, and then my NVidia NForce2 motherboard drivers, booted to safe mode (F8 on boot-up) and ran Driver Cleaner Pro to create as clean a slate as possible for the reinstallation.

It didn’t work. In fact, it made things worse. Now my PC swears blindly that I don’t have a Sound Blaster Audigy 2 installed! Even when I disable the onboard audio in the BIOS. In the end I’ve manually installed the latest driver and I still have problems. The motherboard drivers didn’t install without their own problems either.

I don’t have time for this. But I’m going to have to find it from somewhere. Guess what I’m going to be doing this week … reinstalling Windows XP. AGAIN!!

Come on hardware drivers people, get your PC drivers working properly! It’s not too much to ask now. Is it?

Published by

Gareth Saunders

I’m Gareth J M Saunders, 47 years old, 6′ 4″, father of 3 boys (including twins). Scrum master at Vision Ltd, Dundee. Latterly, web architect and agile project manager at the University of St Andrews and former warden at Agnes Blackadder Hall. Enneagram type FOUR and introvert, I am a non-stipendiary priest in the Scottish Episcopal Church, I sing with the NYCGB alumni choir, play guitar, write, draw and laugh… a lot.

Leave a Reply

Your e-mail address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.