Some days I hate computers!

How difficult should it be to take a couple of quick photographs with my JVC digital camera and transfer those picture files to my PC? You’d think it would be quite an easy task!

Essentially I have two ways of doing it: either remove the MultiMedia Card (MMC) and pop it into my iAPP CR-i500 Digital Memory Card Reader/Writer, or I could simply connect a USB cable to the camera and plug the other end into a free USB port on my PC.

You would think!

Over an hour later and I’m still no further forward. The easiest method is of course to slip the MMC card into my card reader. PC hangs. Reboot. Does it again. Reboot. I remove the card reader from Device Manager, reboot, ‘Unknown Device’ is recognised. CD-ROM of drivers emerges — serious stuff now — only to discover there are no compatible drivers for XP on it, these should be built into XP itself.

Plan B. I’ve installed the USB driver for the JVC camera, and my scanner has now disappeared. Not literally! It’s still on the desk to my right, but as far as My Computer is concerned it is nowhere to be seen. I unplug the scanner, plug it back in, and bing-bong! XP recognises a new device which happens to be my scanner. Card reader is still nowhere in sight.

Right, JVC camera drivers are installed, USB cable is plugged in. Still no camera in My Computer. I install the JVC photo application. And now my blood begins to boil. The application appears to have been made from jelly beans. It looks pretty, but its user-interface is utterly, utterly appalling! The screen is littered with shiny, Mac-like, jelly-bean-like buttons each sporting a symbol that does not intuitively tell me what they do. And there appears neither to be any wizard to step me through the process. After five minutes of poking around, and even reading the online manual, I decide to give up. Reboot.

I reach for Add/Remove Programs in Control Panel, and begin to remove everything I’ve installed this morning. Down the list and back up again. When I arrive back at ATi I decide to repair the HydraVision application, which hasn’t worked for months. Reboot. Oddly, my scanner is back, and so is my card reader. No longer ‘Unknown Device’. I insert the MMC card. PC hangs. Reboot. Card reader has now disappeared, scanner is still there.

And that’s where I currently am. I’m cross, I’m upset and I’ve given up. I suspect that the problem has something to do with conflicting drivers. I also suspect that I may have to move which USB port the card reader is plugged into inside the PC. But I don’t have time for this any more. A full system restore will have to wait. Grrrrr!

Published by

Gareth Saunders

I’m Gareth J M Saunders, 47 years old, 6′ 4″, father of 3 boys (including twins). Latterly, web architect and agile project manager at the University of St Andrews and warden at Agnes Blackadder Hall. Currently on sabbatical. I am a priest in the Scottish Episcopal Church, and I sing with the NYCGB alumni choir.

2 thoughts on “Some days I hate computers!”

  1. Now then! This just *might* be the old supply voltage problem. I know what you’re thinking – “Don’t be daft!” – but not all USB ports supply enough power for some devices. To add to this statement it’s not always obvious which devices will work. For example my Canon USB LIDE scanner worked fine until I changed to a Gigabyte motherboard. Then it would not load it’s driver, would not initialise. Okay, you say, scanners need a lot of power. Next up I had a USB pen drive which did not appear in the drives list once inserted. I fiddled with adding and removing (unnecessary as it happened because XP *does* include drivers, but not recognising the device confuses it)drivers but to no avail. It was the power problem again. The drive letter would intermittently appear and then disappear, accompanied each time by XP’s “ting-tong” noise each time. Power again.

    To test these problems I used a USB 4-port hub – the type that allows an add-on power supply to be used to boost power, which I added. All worked fine! Problem spotted and sorted.

    So annoying as I thought all USB (1 or 2)specs were meant to be the same! Not so.

    It was odd seeing my monster desktop unable to power a scanner, but my lowly laptop handling it fine on battery only!!

    Best o’ luck!

  2. A quick PS to my last missive.

    I sorted the USB power problem more permanently by buying and inserting a new PCI USB 2.0 5-port add-on card. This supplies the “heavier” (or sould I say “correct”) power level some devices need. Plus I get some extra, fast ports. N

Comments are closed.